问题,使用传统的模块化方法安装PHP5.1.* + apache 2.2.2 后不能启动, S(rnVsW%Ki
~bis!(}p-
提示: @Y+kg
"Cannot load C:/php/php5apache2.dll into server: The specified module could not be found." [FBc&HN
Wul8ej:
?q0a^c?A^
原因: vq@"y%C4
"u{ymJ]t
PHP压缩包里的php5apache2.dll只适用于apache2.0.* ;2^zkmDM
0/cgOP!^
解决方法: 6vzvH
)ub!tm
下载 这个文件 并解压.共有三个文件. mXsSOAD<
5bol)Z9BO
vcredist_x86.exe =w:H9uj6F
php5apache2.dll {yi!vw
httpd.exe.manifest #kJ8 qN
0t*PQ%
'8I=Tn
好,开始 7dlMDHp\Y
s"8z q;)
1.将 php5apache2.dll 覆盖掉你原来PHP目录下的 php5apache2.dll 文件. )a+bH </'
Qb;]4[3
2.将 httpd.exe.manifest 文件复制到你的apache安装目录下的bin文件夹下. "kucFf f
kpk ^Uw%f
3.双击运行vcredist_x86.exe安装.(如果您的系统里已安装了 .NET framework 2.就可以省掉这一步) FE#|5;q.
ONc#d'-L
完成!去重启你的apache2.2试试吧.